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Disclaimer and Copyright 

While APRA endeavours to ensure the quality of this publication, it does not accept any 

responsibility for the accuracy, completeness or currency of the material included in this 

publication and will not be liable for any loss or damage arising out of any use of, or 

reliance on, this publication. 

© Australian Prudential Regulation Authority (APRA) 

This work is licensed under the Creative Commons Attribution 3.0 Australia Licence  

(CCBY 3.0). This licence allows you to copy, distribute and adapt this work, provided you 

attribute the work and do not suggest that APRA endorses you or your work. To view a full 

copy of the terms of this licence, visit https://creativecommons.org/licenses/by/3.0/au/ 

https://creativecommons.org/licenses/by/3.0/au/
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Glossary 

APRA Australian Prudential Regulation Authority 

D2A Direct to APRA is software that uses the internet to submit data to APRA. 

Data Information you enter into a form. It may be words, numbers or options you 

have selected. 

Entity A company or institution that submits data to APRA. 

Extranet A secure portal for APRA-regulated institutions to access APRA’s online 

services. 

Form chooser A window that displays the names of all the available returns and forms. 

Period A timeframe (i.e. monthly, quarterly, annually) in which an entity must report 

to APRA. 

Precision The number of decimal places used for monetary values on forms. 

Receipt number A confirmation number provided by APRA to acknowledge receipt of a return 

submission. 

Return A collection of related forms that cover the same period and have the same 

due date 

Return package A group of returns that are due for submission by an entity on the same date. 

SBR Standard Business Reporting, www.sbr.gov.au. 

Scale factor Unit of measure for monetary values, i.e. thousands, millions. 

Submit Sending data to APRA. 

Validate Checking for errors on forms, across a number of forms and between periods 

for the same form. 

XBRL eXtensible Business Reporting Language, www.xbrl.org. 

 

http://www.sbr.gov.au/
http://www.xbrl.org/
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Chapter 1 - Introduction to D2A  

 About D2A 

Direct to APRA (D2A) is a Java based application that enables regulated and non-regulated 

entities to fulfil their reporting obligations to APRA . Using D2A, organisations electronically 

connect with APRA to securely download, complete and submit financial data forms.   

Through D2A, entities can: 

• Download the latest forms required to meet their reporting obligations. 

• Complete forms using manual data entry, or by importing data from XBRL files. 

• Open XBRL instances of forms (version 2.0 or 2.1) 

• Perform validation checks to ensure data conforms to business rules. 

• Perform test submissions to ensure data meets validation rules, etc. 

• Submit data, retrieve previously submitted data, and amend and resubmit forms if 

required. 

 Security 

This release of D2A supports the use of myID. In order to use D2A, entities are required to set 

up their digital identity in myID, including: 

• linking their business and authorising administrators in Relationship Authorisation 

Manager (RAM); and  

• creating machine credentials. 

For more information related to myID, RAM and machine credentials, please refer to the 

relevant ATO website. 

 D2A & SBR 

Standard Business Reporting (SBR) is a multi-agency government initiative to simplifying 

business-to-government financial reporting. It includes an XBRL (XBRL 2.1) taxonomy, which 

enables businesses to identify all of their financial reporting requirements in one place. This 

makes it easier to build or update IT systems to meet reporting requirements for several 

government agencies. For further details of SBR, refer to the federal government website, 

www.sbr.gov.au, or the APRA SBR website, www.apra.gov.au/adopting-standard-business-

reporting-sbr.   

https://www.mygovid.gov.au/
https://info.authorisationmanager.gov.au/
https://info.authorisationmanager.gov.au/business-software-user-or-provider
https://im/teams/IT/TeamWorkspace/D2A%20source%20files%20for%20WWW/www.sbr.gov.au
https://im/teams/IT/TeamWorkspace/D2A%20source%20files%20for%20WWW/%20https:/www.apra.gov.au/adopting-standard-business-reporting-sbr
https://im/teams/IT/TeamWorkspace/D2A%20source%20files%20for%20WWW/%20https:/www.apra.gov.au/adopting-standard-business-reporting-sbr
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The use of the SBR taxonomy in D2A is optional for all entities. D2A is not SBR enabled by 

default and SBR specific functionality is not available. Refer to Enabling SBR. 

Once enabled the current SBR XBRL taxonomy and artefacts can be downloaded.  

An additional XML standards processor add-in, AltovaXML, must be installed and is available 

as a free download from the APRA D2A website. 

When SBR functionality is enabled, SBR XBRL 2.1 instances can be opened, imported, 

validated, and submitted. Refer to Enabling SBR. 

 Getting help 

1.4.1 D2A technical help 

If this publication does not assist with your enquiry or you are experiencing technical 

difficulties with the D2A application, please contact the D2A Help Desk on 02 9210 3400 

between 9am and 5pm (Eastern Standard Time) Monday to Friday, or email 

support@apra.gov.au. 

1.4.2 Help completing forms and return validation errors 

The D2A Help Desk cannot assist with completing forms, or with any validation errors or 

warnings that may be encountered in D2A returns.  

Refer to the Validation and derivation rules page on the APRA website (www.apra.gov.au) for 

information on validation rules, and guidelines for providing explanations.  

For enquiries about validation rules, please contact APRA by emailing 

dataanalytics@apra.gov.au. 

1.4.3 myID, RAM & machine credentials help 

The D2A Help Desk cannot assist with myID, Relationship Authorisation Manager (RAM) or 

machine credential specific enquiries. Please refer to the relevant ATO web page  (myID, RAM 

and machine credentials) or call 1300 287 539.  

mailto:support@apra.gov.au.
https://www.apra.gov.au/validation-and-derivation-rules
http://www.apra.gov.au/
mailto:dataanalytics@apra.gov.au
https://www.mygovid.gov.au/
https://info.authorisationmanager.gov.au/
https://info.authorisationmanager.gov.au/business-software-user-or-provider
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Chapter 2 - D2A installation & setup 

The D2A software is available as a free download from the APRA website, 

www.apra.gov.au/direct-apra-d2a. 

Note: You will need a valid machine credential prior to using D2A. Please refer to Security for 

more information. 

 Prerequisites 

Before installing D2A, ensure you have: 

• Completed the myID and machine credential security requirements.  

- D2A administrators (Principal Authority and Machine Credential Administrator), and 

Extranet users should set up their digital identity and obtain a myID 

- Entities should ensure that their business ABN is linked and administrators are 

authorised in RAM 

- Entities need to create machine credentials for D2A and store these in a different file 

to the current D2A credential. Take note of the password you create and where you 

have saved this file, as you will need to access it later. More information about 

installing a machine credential can be found here. 

Note:  Please contact the ATO and/or refer to the ATO website for specific enquires 

relating to the above steps. 

• A 64-bit Windows computer linked to the internet. 

• Your email address. 

• Your organisation’s Australian Business Number (ABN). 

Note: The ABN used to install D2A must be the same as the ABN defined in RAM (and 

therefore the machine credential). For Super Funds this must be the ABN of the Fund 

Trustee or External Administrator. 

 

 

2.1.1 System requirements 

Supported Operating Systems1 Windows 11 (64-bit) (versions that have not yet reached end-of-

service) 

 

 

1 Although D2A may work with other operating platforms (e.g. Windows XP, Vista, 7, and tablet-specific platforms), 

these are not supported by APRA. 

https://www.apra.gov.au/direct-apra-d2a
https://www.mygovid.gov.au/how-do-i-get-set-up
https://info.authorisationmanager.gov.au/
https://info.authorisationmanager.gov.au/business-software-user-or-provider
https://info.authorisationmanager.gov.au/guide-how-to-install-a-machine-credential
https://www.ato.gov.au/
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Hardware 4GB RAM  

5GB available hard disk free space 

1GHz or faster, 64-bit (x64) processor 

Access Write access to the directory specified by the TEMP 

environment variable and the D2A installation directory. 

Internet access. 

2.1.2 Additional requirements for SBR taxonomy 

If SBR taxonomy is to be used, an XML standards processor add-in is required: 

XML standards processor AltovaXML  

Download from the Installing D2A page of the APRA D2A 

website, www.apra.gov.au/direct-apra-d2a. 

If the AltovaXML utility is installed in a location other than the default, the AltovaXML entries 

in the D2A Client eci.properties file must be updated with the correct location. 

To determine that AltovaXML is installed, open the About window from the Help menu and 

click the SBR tab. The first line should read "AltovaXML libraries loaded". 

 External administrator authorisation 

Using the APRA Extranet, users listed in APRA records as the CEO, CFO, Prudential Contact 

or Company Secretary of an entity can add an agent as an authorised lodger or update the 

funds for which the agent will be submitting or viewing data. 

To add or edit a lodger: 

1. Navigate and login to the APRA Extranet. 

2. In the left navigation bar click D2A > Add Lodger. 

3. Enter the agent’s name and ABN. 

4. From the list, select the funds for which the agent will be submitting or viewing data. 

5. If you have not previously authorised this agent, under Is this a change of agent? select 

Yes. 

6. Select the date from which the changes take effect.  

7. Click Request. 

A message is displayed and you will receive email notification that your request has been 

submitted. APRA will contact you to finalise authorisation of the agent. 

Note: If you are unable to use the APRA Extranet to complete the agent authorisation 

process, please download and complete the Agent Authorisation form, and send the original 

to the APRA Registrar. 

https://www.apra.gov.au/downloading-and-installing-d2a
https://www.apra.gov.au/direct-apra-d2a
https://extranet.apra.gov.au/
https://www.apra.gov.au/auskey-acknowledgement
mailto:registrar@apra.gov.au
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 Installing D2A 

2.3.1 Standard installation 

To install D2A: 

1. If you have a version of D2A prior to v7.0 installed, this must be uninstalled. 

Note: Ensure your existing machine credentials (keystore.xml) are not removed.  

2. Download the D2A installation file from the D2A web page.  

3. From the downloaded .zip file, extract the .exe file to a secure location on your computer. 

4. Double-click the .exe file to run it. 

 

5. Read the Introduction and click Next. 

 

6. Read the License Agreement and select I accept the terms of the License Agreement to 

confirm your acceptance. 

 

https://www.apra.gov.au/downloading-and-installing-d2a
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7. Click Next. 

8. Choose the location on your computer where D2A will be installed. 

Note: If you require multiple installs of D2A on the same machine, each installation must 

be installed to a separate folder. 

You must have write permission to the selected location. 

 

9. Click Next.  

10. Enter your Australian Business Number (ABN), without spaces, and click Next. 

 

11. Enter your email address and click Next. 

 

12. Confirm that the install location, ABN, and email address are correct. 
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Note: If this information is incorrect and you complete the installation, it cannot be 

changed within the application. D2A will need to be uninstalled and then reinstalled with 

the correct details. 

 

13. Click Install. 

 

14. When the installation is complete, click Done. 

 
Once installed, D2A is available from the Start menu, select All Programs > APRA Tools > 

D2A. 

15. Configure firewall and proxy settings. 

16. Check your installation. 
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2.3.2 Silent installation 

D2A supports silent installation mode. In a silent installation you will not see the standard 

installation wizard, and as the required values are predefined you do not need to manually 

key in install directory, ABN or email. 

The following steps provide guidance on setting up and launching a silent (non-wizard) D2A 

installation. 

To perform a silent install of D2A: 

1. Download the D2A installation file from the D2A web page.  

2. From the downloaded .zip file, extract the .exe file to a locally accessible location, 

e.g. c:\temp. 

3. Create a file call “installer.properties” in the same location as the .exe file. 

4. Add the following details to the properties file, with the values applicable to your 

organisation (the value for INSTALLER_UI is set to “silent” to initiate silent installation).  

INSTALLER_UI=silent  

USER_INSTALL_DIR = <directory where D2A is to be installed> 

CUSTOM_DIALOG_ABN = <your ABN> 

EMAIL_ADDRESS_VAR = <your email address>  

e.g. 

INSTALLER_UI=silent  

USER_INSTALL_DIR = C:\D2A 

CUSTOM_DIALOG_ABN = 11300000659  

EMAIL_ADDRESS_VAR = AppDev@sample.com.au  

5. Launch an elevated (admin) command prompt and change the directory to the location of 

the .exe and properties files.  

(To launch an elevated command-prompt, click Start and type “cmd”. Right-click the 

Command Prompt search result and select Run as administrator.)  

6. In the command prompt, type D2A.exe and press Enter to start the silent installation.  

If you encounter issues with installation, double-check the input values defined in the  

installer.properties file, and refer to the log file “lax-xxxx-out.txt” created in the folder where 

the .exe file is located, e.g. c:\temp\ as in the example above.  

Alternate option for silent installation 

Silent installation can also be run from the command line using -D arguments instead of 

installer.properties file approach.  

If using this approach, ensure the installer.properties file does not exist in the directory 

where D2A.exe is placed. 

https://www.apra.gov.au/downloading-and-installing-d2a
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A sample command using -D arguments is shown below (the values of the parameters to be 

modified as applicable to your organisation): 

 location of the .exe file> D2A.exe -i silent -DUSER_INSTALL_DIR=directory where D2A is to be 

installed  

-DCUSTOM_DIALOG_ABN=your ABN  

-DEMAIL_ADDRESS_VAR=your email address 

e.g.  

C:\temp> D2A.exe -i silent -DUSER_INSTALL_DIR= C:\D2A  

-DCUSTOM_DIALOG_ABN=11300000659  

-DEMAIL_ADDRESS_VAR= AppDev@sample.com.au 

Notes:  

1. Provide a valid installation directory where D2A is not already an installed.  

2. Running D2A.exe with the installer.properties file, but without INSTALLER_UI=silent 

included,  will launch a standard (non-silent) install, with the values for install location, 

ABN and email input fields pre-populated.  

 Setting up your machine credential  

Once you have successfully installed D2A, you will need to setup your machine credential in 

the appropriate location before using D2A.  

To setup your machine credential: 

1. Locate your machine credential.  

If you have followed the prerequisites by creating the machine credential in RAM, it 

should be in its default location, C:\users\yourusernamename\AppData\Roaming\ATOMAS.  

2. Copy and paste your machine credential into the AUSkey folder.  

The default location for this folder is C:\users\yourusername\AppData\Roaming\AUSkey. If 

you do not see an AUSkey folder, please create the folder manually.  

3. Rename the pasted file to “keystore.xml”, or “keystore” if extensions are not visible (the 

file Type must be XML Document).  

Note: If there is already a keystore.xml file in the AUSkey folder and it dates prior to 1st April 

2020, delete it and replace it with your new machine credential. If any other keystore files are 

located in the folder (e.g. keystore_Auskey), these should be deleted as they no longer work 

with D2A.  

2.4.1 Expiring machine credentials 

Machine credentials expire two years from the date of creation. You will receive no 

notification if your machine credentials have expired. If they have already expired, the 

credential prompt in D2A will hang when you enter the correct password and will give you an 

incorrect prompt when you enter an incorrect password. 
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You need to replace your expired machine credential to ensure continued use of D2A.  

Checking expiration date 

There are two ways to check the expiration date of your machine credentials: 

• Through RAM:  

1. Log into RAM. 

2. Select Manage Authorisations. 

3. Select your organisation. 

4. Select Manage Credentials. 

5. Find your machine credential. 

6. Click Edit to view the expiry date.  

• In the Keystore file:  

1. Locate the Keystore.xml file in the AUSkey folder; 

(C:\users\yourusername\AppData\Roaming\AUSkey). 

2. Open the Keystore file in Notepad.  

3. Search for the “not after” date. 

Replacing machine credentials 

To replace your existing machine credentials: 

1. Check the ATOMAS folder (C:\users\yourusernamename\AppData\Roaming\ATOMAS) for a 

file called "Keystore-new".  

2. If there is a "Keystore-new" file, either delete it or move it to another location. 

3. Check the AUSkey folder (C:\users\yourusername\AppData\Roaming\AUSkey) for files 

called "Keystore-new" or "Keystore". 

Either delete the files or move them to another location. 

4. Create a new machine credential (click here and refer to the video for detailed 

instructions). 

5. Locate your machine credential. It should be in its default location, 

C:\users\yourusernamename\AppData\Roaming\ATOMAS.  

6. Copy and paste your machine credential into the AUSkey folder. The default location for 

this folder is C:\users\yourusername\AppData\Roaming\AUSkey. 

7. Rename the pasted file to “Keystore.xml”, or “Keystore” if extensions are not visible (the 

file Type must be XML Document). 

https://authorisationmanager.gov.au/#/login
https://info.authorisationmanager.gov.au/business-software-user-or-provider
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 Firewall & proxy settings 

When installing and setting up D2A, it is important to understand your server and security 

configuration to ensure D2A can communicate successfully with APRA. Firewalls and proxy 

server settings may need to be configured in order to enable D2A to connect with the APRA 

servers. 

2.5.1 Firewall settings 

If firewall restrictions are in place these must be assessed by your IT department.  

All the relevant information concerning communication with the APRA server, including the 

URL and IP address, is available in the eci.properties file stored in the D2A installation folder.  

To enable information to pass successfully through the firewall, your IT department must 

ensure that permission is given to the APRA server URL and IP address. 

2.5.2 Defining a proxy server 

If your network uses a proxy server to access the internet, you need to set proxy server 

options within D2A. Contact your IT department to determine whether a proxy server is used 

to access the internet and the required proxy setting details. 

If your organisation’s proxy server requires authentication to access the internet, whenever 

D2A attempts to communicate with APRA via your network proxy, the HTTP Authentication 

window is displayed. You must enter your domain user name and password. 

Note: D2A will not work through proxy servers requiring Microsoft NTLM authentication. 

To define a proxy server in D2A: 

1. From the Tools menu, select Options to open the Options window. 

2. Click the Proxy tab. 

 

3. In Host Name, enter the name or IP address of your internet/HTTP proxy server. 

4. In Port, enter the TCP port used for the internet/HTTP proxy. This defaults to 80. 

5. Click OK to apply the settings. 
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 Setting password timeout 

You can set a period of minutes during which your D2A session remembers your password 

and you will not be prompted to re-enter your password, unless submitting or saving a 

return.  

Each time you communicate with APRA the timeout interval restarts. If the interval is set to 

zero, you will be prompted for your password each time you communicate with APRA. 

To set a password timeout period: 

1. From the Tools menu, select Options to display the Options window. 

2. Click the Password Timeout tab. 

 

3. In the Password Timeout Interval (mins) field, enter the desired number of minutes. 

4. Click OK. 

 Checking your installation 

The easiest way to check your installation and ensure D2A is ready for you to begin 

submitting data to APRA, is to request new forms. 

To request forms: 

1. From the Tools menu, select Request All New Blank Forms. 

2. Enter your security details and click OK. 

3. When the forms download is completed successfully, click OK. 

 Setting auto recovery options 

When auto recovery is enabled, if D2A encounters a problem and stops responding it will 

attempt to recover the return or form that was open at that time.  

Recovery files are only retained on the system for the duration of the current D2A session. 

When the user successfully exits D2A, the recovery files are automatically removed from the 

system. 
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Note: This functionality does not replace the Save command. Refer to Saving forms & 

returns. 

To set auto recovery options: 

1. From the Tools menu, select Options to open the Options window. 

2. Click the Auto Recovery tab. 

 

3. Select Enable Auto Save. 

4. In Auto Save Interval (mins) enter the frequency, in minutes, at which recovery files are 

created 

5. Click OK to apply the settings. 

 Uninstalling D2A 

Uninstalling D2A deletes all files in the D2A directory. If you want to retain any saved forms, 

they must be moved to another location. 

To uninstall D2A: 

1. Close the D2A application if it is running. 

2. Open File Explorer and navigate to the D2A folder (The default location is C:\D2A). 

3. Open the UninstallerData folder. 

4. Double-click the Uninstall D2A.exe file. 

5. Follow the prompts to uninstall this instance of D2A. 

6. Once uninstall is successful, return to the C drive and delete the D2A folder. 
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Chapter 3 - Forms & returns 

 Forms & returns 

Data is entered into D2A and submitted to APRA using forms and returns. 

A form is a set of information related to a single topic. Forms contain fields and lists 

structured to collect and deliver data in the required format.   

A return is a collection of related forms that cover the same period and have the same due 

date. Each return may apply to several periods. These are listed in the D2A Form Chooser 

window under a parent folder with the name of the return, as shown in the following images:  

 

Figure 1. Sample return period list 

Forms must be submitted together as a return; however, forms can be opened and 

completed individually.  

Returns can also be submitted as a package, see Return packages for further details. 

D2A features assist you to complete and submit your forms correctly and on time. D2A 

enables: 

• You to save a partially completed form, to return to later.   

• Different people to work on individual forms in the same return, then combine into a 

single return for submission. 

• Different people to work on separate parts of the same form, then combine the 

information before submitting.  

• XBRL data to be imported from your financial system into a form. 

• Validation to find errors and highlight anomalies on forms before submitting to APRA.   

Refer to the section of the APRA website (www.apra.gov.au) that relates to your organisation 

type for assistance with completing forms. 

http://www.apra.gov.au/
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 Form completion & validation process 
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Open return
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4
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8
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No
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Figure 2. Form completion and validation process 

See Validating forms & returns for validation details. 

See Submitting a return for submission details. 

 Multiple entities — Updating entities list 

If your organisation submits returns on behalf of multiple companies or reporting entities, i.e. 

uses multiple ABNs, when you request new forms D2A displays the Entity Chooser listing your 

associated entities.  

To update the Entity Chooser: 

1. From the File menu select New, or click the New  toolbar button. 

2. On the Entity Chooser window, click Update. 

 

3. Enter your security details and click OK. 

D2A downloads your entities list. 

4. When the download is complete, click OK. 

Note: If not all the expected entities are listed, contact the APRA registrar. 
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 Requesting forms 

The first step in submitting data to APRA is to request the forms. This ensures you have the 

latest versions and the correct forms to submit.  

D2A only downloads the forms that are required by your organisation.  

To request forms: 

1. From the File menu select New, or click the New  toolbar button. 

Note: If you submit data on behalf of multiple entities, D2A displays the Entity Chooser 

window, which enables you to request forms for a single entity.   

You can also download forms for all entities in a single request; refer to Requesting all 

forms for multiple entities. 

2. On the Form Chooser, click Refresh.  

3. Enter your security details and click OK. 

4. When the forms download is complete, click OK. 

The Forms Chooser displays return periods due within the next 8 weeks.  

Returns that have previously been submitted are indicated with a red tick.  

 
Selecting to open a previously submitted return from the Forms Chooser opens new (i.e. 

empty) forms. See Downloading previously submitted returns for details of accessing 

submitted data. 

3.4.1 Requesting all forms for multiple entities 

To download forms for multiple entities in a single request: 

1. From the Tools menu, select Request All New Blank Forms. 

2. Enter your security details and click OK. 

D2A sends a request to APRA to download all forms for the entities for which you are 

responsible. 

3. When the forms download is complete, click OK. 

 Opening forms & returns 

You can open either an entire return or an individual form within a return. 

Opening a return opens all the forms for that return. You can move between forms to 

complete the details of each form.  

Opening an individual form opens only that form. Before opening an individual form, you 

should determine whether the selected form requires validation or derives values from other 

forms in the return. 



AUSTRALIAN PRUDENTIAL REGULATION AUTHORITY  23 

 

Note: Individual forms cannot be submitted. See Importing data from saved forms for details 

of combining forms into a return. 

To open a return or form: 

1. Request forms to ensure you have the most recent versions and the correct forms for 

submission. 

2. In the Form Chooser, select either the required return or the required form to open. 

3. Click New. 

The selected forms are available in the tree view in the left pane of the D2A window. 

 

3.5.1 Opening a previously saved form or return 

To open a saved file: 

1. From the File menu select Open, or click the Open  toolbar button. 

2. In the Open window, browse for and select the required file. 

3. Click Open. 

3.5.2 Closing a form or return 

To close a form or return, either select Close from the File menu, or click the Close  

toolbar button. 

 Entering data 

Data can also be imported into D2A, see Importing data for further details. 

3.6.1 Copying & pasting data 

Data can be copied from another application or spreadsheet into D2A fields and tables. When 

copying and pasting data you should be aware of the following: 

• Copying invalid characters into a form may corrupt the submitted xml file. Invalid 

characters include any non-alpha numeric (special) characters, e.g. ? } ~ | etc.  

• Derived fields that are part of a table will be populated by pasting data. 

• Derived fields that are not part of a table will not be populated by pasting. 



AUSTRALIAN PRUDENTIAL REGULATION AUTHORITY  24 

 

• For best results, arrange data as it appears in the D2A form (with the exception of 

derived fields not part of a table). 

3.6.2 NIL forms 

If an individual form in a return does not apply to your organisation, does not apply for this 

period or you have no data to report, select NIL Form. This indicates to APRA that the form is 

not applicable to you and means that you do not need to enter any data. 

 

3.6.3 Default data  

Some form information, such as names and addresses, is populated by default from the 

APRA database. Complete all other fields. 

3.6.4 Form level data validation 

D2A performs validation checks as data is entered into a form. Errors are highlighted with a 

red box around the applicable field. Data errors must be corrected before you can move to 

the next field. 

3.6.5 Data types 

Values entered in form fields may be one of three types: 

• Text 

• Numeric (non-monetary) 

• Monetary  

All monetary values must have the correct scale factor (whole dollars, thousands or 

millions) and the correct number of decimal places (precision). The scale factor defines 

whether the value entered is translated to a larger figure, e.g. a scale factor of thousands 

translates a value of 600 to 600,000. A scale factor of whole dollars means values remain 

as entered. 

The precision and scale factor are defined for each form and are displayed in the header 

of the form. 
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3.6.6 Adding rows to tables 

If you require more rows in a table than are supplied by default: 

1. Move the mouse to the required table. 

2. Right-click and select Add new row. 

A new row is added at the bottom of the table.  

You can also remove rows by right-clicking a table and selecting the applicable option. 

 Saving forms & returns 

Forms and returns can be saved when complete or partially complete. When a return is open, 

all forms in the return are saved. When a single form is open, only that form is saved.  

Large forms should be saved at regular intervals to minimise the risk of losing data due to an 

interruption to your computer. 

To save a form or return, either select Save from the File menu, or click the Save  toolbar 

button. 

To save another copy, either select Save As from the File menu, or click the Save As  

toolbar button. 

 Printing forms & returns 

Forms and returns can be printed at any time.  

If an entire return is open, all forms in the return are printed, i.e. not just the form visible in 

the right-hand pane. 

To print a form or return: 

1. Open the form or return you want to print.  

2. From the File menu select Print, or click the Print  toolbar button. 

3. On the Print window, click OK. 

The form or return is sent to the default printer. 

3.8.1 Print PDF 

PDF versions of select forms and returns can be created using the Print PDF option from the 

File menu or the Print PDF  toolbar button.  

If you receive the error, “Can't do Print PDF.... The option to Print PDF is currently unavailable for 

the selected form(s).” the Print PDF option is not available for the form. 
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 Importing data from saved forms 

You can import data from saved forms or returns, into either new forms or forms that already 

contain data.  

When SBR is enabled, data can also be imported from an XBRL file. Refer to Importing an 

SBR XBRL form. 

Importing saved forms can be used to: 

• Complete a form if different people worked on separate parts of the same form. 

• Create a single return for submission, if forms are completed by different people on 

different computers. 

Forms must be of the same type and version as the return into which they are imported, e.g. 

a form from a monthly return cannot be imported into a quarterly return.  

When importing to an existing form: 

• If a field contains different values in both forms, you must select which value to use.   

• If a field contains a value in one form and is blank in the other, the blank field is ignored 

and the data from the completed field is used. 

To import form data: 

1. Open the form or return into which you want to import. 

If you open a return, ensure you select the required form in the left pane tree view. 

2. From the File menu, select Import or click the Import  toolbar button. 

3. You will be prompted to save the form. Click Yes and follow the prompts. 

Ensure the location and file name given to the form does not overwrite the form to be 

imported. 

4. From the Import window, browse to and select the form to import. 

5. Click Import.   

If there are no conflicting values, the data is imported. If the existing value is zero, it is 

not considered to be a conflict. 

If conflicting data is identified, the Resolve Import Conflicts window is displayed. This 

lists the affected fields and the conflicting values. If importing into a return, conflicts for 

each form are displayed on a separate tab.  
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6. For each conflicting field: 

- To use the data from the imported form, select Use Imported?.   

- To retain the existing value, leave Use Imported? unselected. 

 

7. Click OK. 

 Opening XBRL 2.0 returns 

Data that has been converted to XBRL 2.0 format can be opened in D2A for submission. 

XBRL® (eXtensible Business Reporting Language), is a freely available electronic language 

for financial reporting. It is an XML-based framework that provides the financial community 

with a standards-based method to prepare, publish in a variety of formats, reliably extract 

and automatically exchange financial statements information. 

An automated XBRL conversion process implemented into an entity’s system can eliminate 

much of the manual data entry that may be required to complete D2A forms. 

XBRL 2.0 is superseded by the APRA SBR taxonomy (XBRL 2.1). Refer to Enabling SBR for 

details of using SBR XBRL instances. 

3.10.1 Opening a single XBRL file 

To open a single XBRL file: 

1. From the XBRL menu select Open XBRL Return 2.0, or click the Open XBRL  toolbar 

button. 

2. From the Import XBRL window, browse to and select the .xml file to open. 

3. Click Open.   

D2A opens the new blank return referenced in the XBRL file and imports the data.  

4. When the import is complete click OK. 

 Enabling SBR 

By default, SBR specific functionality is not available. SBR functionality should only be 

enabled if an organisation is using the SBR XBRL 2.1 taxonomy to tag their data. 

For further information regarding the APRA SBR taxonomy, refer to the APRA SBR website, 

www.apra.gov.au/adopting-standard-business-reporting-sbr. 

https://www.apra.gov.au/adopting-standard-business-reporting-sbr
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For plain English definitions of individual field attributes, refer to PET (Plain English 

Taxonomy) available on the APRA SBR web site at www.apra.gov.au/adopting-standard-

business-reporting-sbr. 

In order for the SBR functionality to work correctly, the AltovaXML XML standards processor 

is required. Refer to Additional requirements for SBR taxonomy. 

To enable SBR: 

1. Request all new blank forms. 

2. From the XBRL menu, select Enable/Disable SBR. 

3. From the XBRL menu, select Refresh SBR.  

The current XBRL taxonomy is downloaded and SBR functionality is enabled.  

3.11.1 Generating a sample XBRL form 

To better understand the integration requirements between your systems and D2A, you can 

generate an SBR XBRL 2.1 instance file of an individual form and its data. 

The generated file is for test and sample purposes only and should not be used in a 

production system or as a guaranteed template. 

To generate a sample XBRL instance: 

1. Open an individual form. 

Note: Open a single form, not an entire return. 

2. From the XBRL menu, select Generate Sample Form (XBRL 2.1). 

3. Browse to the location in which to save the generated file. 

4. Enter a file name for the exported file and click OK. 

The generated XBRL 2.1 file contains the data of the selected form. The file is validated 

against the appropriate SBR reporting taxonomy and the results are presented in the 

progress window.  

Note: Validation against the reporting taxonomy is not the same as the data validation 

performed prior to submission. 

3.11.2 Opening SBR XBRL files 

You can open a single instance file, a number of individual files, a directory or a zip file. 

Selecting a directory opens all .xml contained within it. Zip files are unzipped to a temporary 

location before being opened in D2A. 

https://www.apra.gov.au/adopting-standard-business-reporting-sbr
https://www.apra.gov.au/adopting-standard-business-reporting-sbr
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When selecting an XBRL 2.1 instance file, a directory containing XBRL 2.1 instance files or a 

zip archive containing XBRL 2.1 instance files, all files must belong to the same return. If the 

files do not form a complete return, the return cannot be submitted. To use files that do not 

comprise a complete return, use the Import facility. If a selected directory or zip file contains 

files for multiple returns, D2A opens only the files linked to the same return as the first file to 

be accessed. 

For each file opened, the XBRL validation and import progress dialog box displays the results 

in succession. Data items may be omitted, however each XBRL instance file must be validated 

against the XBRL reporting taxonomy to be opened successfully. Failure of one file to be 

opened does not prevent subsequent files from opening. 

Opening an XBRL 2.1 SBR file is almost identical to the process of opening an XBRL 2.0 file: 

1. From the XBRL menu select Open SBR Return (XBRL 2.1), or click the Open SBR Return 

(XBRL 2.1)  toolbar button. 

2. In the Import XBRL window, browse to and select the .xml file(s), directory or zip file to 

open.  

3. Click Open.   

4. When complete, click OK. 

3.11.3 Importing an SBR XBRL form 

You can import data from an individual SBR form into either a new form or a form that 

already contains some data. 

To import an SBR form: 

1. Open the form into which you want to import. 

If you open a return, ensure you select the required form in the left pane tree view. 

2. From the XBRL menu, select Import SBR Form (XBRL 2.1).  

3. In the Import XBRL window, browse to and select the file to import.   

The selected file includes the data for a single form and reporting consolidation that is 

part of the current return. 

4. Click Import.   

If the data is valid against the XBRL reporting taxonomy, the data import commences. If 

there are no conflicting values, the data is imported. 

If conflicting data is identified, the Resolve Import Conflicts window is displayed. This 

lists the affected fields and the conflicting values.  
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5. For each conflicting field: 

- To use the data from the imported form, select Use Imported?.   

- To retain the existing value, leave Use Imported? unselected. 

 

6. Click OK. 

 Validating forms & returns 

You can validate a form or return at any time during the data entry process. During the 

validation process, D2A completes all calculations and derived data fields. The validation 

process checks for errors, inconsistencies, anomalies and invalid field entries. Derived or 

calculated fields are grey and cannot be edited.  

Note: Explanation text must either be entered directly into the Validation window or copied 

from a plain text editor, such as Notepad.  

Do not copy text from applications such as Excel or Word, as this may corrupt the submission 

file and cause a submission failure. 

3.12.1 Refreshing validation rules 

Before validating, it is important to have the latest validation rules.  

To refresh the validation rules: 

1. From the Tools menu select Validation then Refresh Rules, or click the Refresh Rules  

toolbar button. 

2. When the refresh is complete, click OK. 

3.12.2 Validating forms  

All forms must be validated before submission. There are three types of checking performed: 

Check Description 

Mandatory Mandatory validation errors must be corrected and revalidated prior to 

proceeding with the data submission. You cannot submit a return with 

mandatory errors.  

Confirmation/ 

Warning 

Confirmation validation errors highlight data discrepancies or abnormal 

variations. These often relate to typographical or transposition errors. In 

some cases, the data is accurate.  
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Check Description 

In cases where the data is correct, you must confirm that you have checked 

the data and provide an explanation for the discrepancy in order to submit the 

return. 

Cross form or  

cross return  

Cross form validation errors occur when there are discrepancies in expected 

values when compared across multiple forms. For example, the same field 

may be expected to have the same value across multiple forms in a return. 

Cross form validation requires an entire return to be open. 

Cross return validation errors occur when there are discrepancies in expected 

data item values when compared with values in different returns. 

See Figure 2 for a flow chart of the form completion and validation process. 

To validate a return and complete all derived and calculated fields: 

1. From the Validation menu select Validate, or click the Validate  toolbar button. 

2. If errors: 

- are not found, the Validation Progress window indicates “There are no validation 

errors or warnings. Complete”. 

Click OK. 

- are detected, the Validations window displays the errors found. Errors for individual 

forms are displayed on separate tabs. Go to step 3. 

 

3. Your next step depends on the type of error found: 

Error Action 

Mandatory Errors Correct the data and re-validate. 

Confirmation/ 

Warning 

Check the data. If the data is: 

• Incorrect, correct the data and re-validate. 

• Correct, select Confirm and add a comment to explain why there 

is an anomaly with the data. 

Note: Text must either be entered directly into the Validation window or 

copied from a plain text editor, such as Notepad. 



AUSTRALIAN PRUDENTIAL REGULATION AUTHORITY  32 

 

The Validation window includes several options for recording the errors displayed: 

- Print – sends errors to your default printer. 

- Copy – copies the errors to a txt file. 

- Export – exports errors to a csv file. 

For more information on validation rules and guidelines for providing explanations, refer to 

the Reporting framework page for your industry type on the APRA website, www.apra.gov.au.  

http://www.apra.gov.au/
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Chapter 4 - Submitting to APRA 

 Performing a test submission 

D2A enables you to perform a simulated submission of your return in test mode to identify 

any submission errors that may be encountered. Test mode simulates submission but does 

not send data to the APRA system. 

When in test mode the D2A window title bar displays “Test Mode” appended to the open 

return name and the toolbar background colour changes to yellow.  

Note: Test mode cannot be used with return packages. 

To submit a return in test mode: 

1. From the Test Mode menu select Use Test Mode. 

2. From the File menu select Submit, or click the Submit  toolbar button. 

3. Enter your security details and click OK. 

4. If no errors are detected, the Information window displays "Test Mode: actual submission 

disabled". 

5. Click Close. 

To disable test mode, select Test Mode > Use Test Mode. Test mode does not persist 

between sessions. 

 Submitting a return 

Only whole returns can be submitted to APRA. Each form in a return must be completed and 

validated prior to submission, to reduce the number of potential error messages during 

submission. 

To submit a return: 

1. Open the required, completed and validated return. 

Note: The submit options are only available if a whole return is open. 

2. From the File menu select Submit, or click the Submit  toolbar button. 

3. Enter your security details and click OK. 

4. If no errors are detected during submission, the Information window is displayed 

containing your submission reference number.   

Keep a note of your reference number. 

5. Click Close. 
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When the data has been accepted into the APRA system, a confirmation email is sent to the 

address attached to your D2A Installation.  

Note: To check this email address, open the About window from the Help menu. 

D2A needs to be re-installed to change this email address. 

4.2.1 Resubmitting a return 

A return can be resubmitted at any time if changes need to be made to data after the initial 

submission.  

Make the required changes and submit the return again. APRA will recognise that this is not 

your first submission for the period and automatically use the most recent data. 

 Downloading previously submitted returns  

You may be required to access returns submitted to APRA in a previous period. You can view 

lists of previous returns within D2A and download returns as required. 

You can view submitted returns grouped in four different ways: 

return – form Returns are grouped by return, period then form. 

return – revision – form Returns are grouped by return, period, revision then form. 

consolidation – form – period Forms are grouped by consolidation type, then by form and 

period. 

consolidation – period - form Forms are grouped by consolidation type, then by period and 

form. 

 

Note: Returns marked with ‘Processing at APRA’ can be downloaded if one or more forms 

have finished processing. Only the latest available forms are downloaded. 

To view and download previous returns:  

1. From the Tools menu select Get Data, or click the Get Data  toolbar button. 

2. Enter your security details and click OK. 

3. In the Return Chooser, select the tab of the required view. 

 

4. Select the required folder of returns or form. 
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5. Click Download. 

6. When the download is complete, click OK. 

The selected form is opened. The form can be saved, printed, or closed as required. 

 Return packages 

A return package is a group of returns that are due on the same date. Only specific 

organisations and industries are required to submit packages.  

If your organisation is required to submit return packages, they are displayed in the Form 

Chooser window under Return Packages as shown below. 

 

All the same functions apply for opening and completing forms and returns within a package, 

as are available for individual returns. 
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4.4.1 Return package completion and submission process 
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Figure 3. Return package completion and submission process 

4.4.2 Saving draft returns to APRA 

Before an entire package can be validated and submitted, each individual return must be 

completed and saved as a draft to APRA 

D2A only allows you to save a complete return as a draft at APRA. Single forms cannot be 

saved as a draft. You must validate the return before saving it to APRA.  

Note: This function is only applicable to returns in packages. 

To save a draft return to APRA: 

1. With the completed return open, from the Return Package menu select Save Draft at 

APRA, or click the Save Draft at APRA  toolbar button. 

D2A runs validation checks and if there are no errors, displays the Save Draft Progress 

window. 

2. If errors are identified, review any error messages and take corrective actions. See 

Validating forms for descriptions of validation error types. 
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3. Enter your security details and click OK. 

D2A connects to the internet, checks the authentication credentials and saves the draft 

return.  

4. The Information window is displayed containing your reference number. 

Keep a note of the reference number. 

5. Click Close. 

When the data has been accepted into the APRA system, a confirmation email is sent to the 

address attached to your D2A Installation. 

4.4.3 Submitting a return package 

To submit a return package, each return must be completed, validated and saved as a draft to 

APRA. 

Only once the entire return package is submitted will the information in the return be used in 

the monitoring and reporting functions of APRA. 

To submit a return package: 

1. From the Return Package menu select Validate Return Package, or click the Validate 

Return Package  toolbar button. 

2. Enter your security details and click OK. 

3. Review any error messages and take corrective actions. See Validating forms for 

descriptions of validation error types. 

4. From the Return Package menu select Submit Return Package, or click the Submit 

Return Package  toolbar button. 

5. Enter your security details and click OK. 

6. If no errors are detected during submission, the Information window is displayed 

containing your submission reference number.   

Keep a note of your reference number. 

7. Click Close. 

When the data has been accepted into the APRA system, a confirmation email is sent to the 

address attached to your D2A Installation.  

4.4.4 Resubmitting a return 

As with individual returns, a return package can be resubmitted at any time if changes need 

to be made to data after the initial submission.  

Make the required changes and submit the package again. APRA will recognise that this is 

not your first submission for the period and automatically use the most recent data. 
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4.4.5 Downloading submitted packages or saved returns 

Downloading a previously submitted return package or a draft return saved to APRA, follows 

the same steps as described in Downloading previously submitted returns. 

The Return Chooser window displays additional details for packages and saved drafts: 

Tab Description 

return – form Returns are grouped by return package, return, period 

then form. 

Submitted packages are displayed under the Submitted 

Return Package folder for a period. 

Saved returns are displayed in the Draft Returns folder 

for a period. 

return – revision – form Returns are grouped by return package, period, package 

revision, return then form. 

Submitted packages are displayed under the Submitted 

Return Package folder for a period. 

Saved returns are displayed in the Draft Returns folder 

for a period. 

Use this tab to View Confirmation errors for a selected 

return package. 

consolidation – form – period Forms are grouped by consolidation type, then by form, 

period and return. 

‘Draft’ appears after the name of saved returns. 

consolidation – period - form Forms are grouped by consolidation type, then by period, 

form and return. 

‘Draft’ appears after the name of saved returns. 

 

Note: Returns marked with ‘Processing at APRA’ can be downloaded if one or more forms 

have finished processing. Only the latest available forms are downloaded. 
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